Darktable Flickr Export fixen

Ich wollte mal wieder ein paar neue Photos aus Darktable nach Flickr schubsen und stellte fest, dass die Flickr Authentifizierung mit dieser Fehlermeldung scheiterte:

Hoppla! Flickr erkennt den Frob nicht, den diese Anwendung zu verwenden versucht.

Ein bisschen Googlen half mit, diese wirklich sehr aussagekräftige Fehlermeldung aufzulösen und den Flickr-Export wieder zum Laufen zu bringen.

Flickr hat ja schon seit längerer Zeit seine API auf striktes SSL mit HTTPS umgestellt. Das gab schon bei so manch anderer Anwendung ein böses Erwachen (SSL Fehler bei Flickr Plugin für WordPress).

Darktable ist insofern auch betroffen, als dass es für die Verbindung zu Flickr die flickcurl Bibliothek benutzt, die bisher noch ohne https-connections arbeitet.

Hier schafft ein Workaround Abhilfe, sofern ihr Darktable unter einem Ubuntu 14.10 LTS einsetzt:

Fügt diese PPA-Quelle eurer Ubuntu Aktualisierungsverwaltung hinzu:

Pascal de Bruijn merkt aber an, dass ihr diesen Fix auf eigene Gefahr hin benutzt.

Mehr dazu hier.

Nach einem Darktable Neustart war es kein Problem, sich bei Flickr zu authentifizieren und die Bilder hochzuladen.

 

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.